Our commercial plugins offer support for features that are not part of the WebRTC specification which you may choose to include or exclude at build time.


One such feature is H.264 enabling which can be requested at the time of a plugin build.


H.264 is a video codec natively not implemented in libWebRTC. Temasys uses openH264 in the plugin to add support to H.264. Please note that the openH264 dll is neccessary for the plugin to work.


Now H.264 usually requires royalties to be paid. In order to avoid either Temasys or our clients being liable for royalties, we use a dynamic library built, implemented and distributed by Cisco called openH264 (The same system that Firefox uses).  For further details, please view this video as well as our Troubleshooting Documentation.


You can use the HasH264Support API to check if your plugin has H.264 enabled.


If the API shows that your plugin is not H.264 enabled and you would like an H.264 enabled plugin, please contact the Customer Relations and Sales team at sales@temasys.io to request for an H.264 enabled build.




Please note that the dynamic library MUST be downloaded and installed while the plugin is installed, not when it is built. Installation requires internet connection.

This means that plugins with H.264 enabled require an internet connection at install time that does not block the download.



Other articles you may be interested in:

 

What is Open H.264?

FAQs about Open H.264

Plugin Installation is Blocked when Open H264 is downloaded